Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: OfflineWeb Lounge. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

41

Montag, 9. Mai 2011, 11:38

Fehlermeldung

Warning: require_once(DbModule.php) [function.require-once]: failed to open stream: No such file or directory in /srv/www/httpd/phost/e/de/emderonline/web/wbb/go/deich_hof.php on line 3



Fatal error: require_once() [function.require]: Failed opening required 'DbModule.php' (include_path='.:/srv/www/httpd/phost/e/de/emderonline/web') in /srv/www/httpd/phost/e/de/emderonline/web/wbb/go/deich_hof.php on line 3

bekomme beim klick auf hall of fame und spielregeln die obige fehlermeldung hat jemand ne idee woan es liegen koennte


gruss house



42

Montag, 9. Mai 2011, 15:02

Grund dafür steht mehrfach in dem Thread hier.. Mal neu saugen.. Ist im DL ja gefixt. Steht auch weiter oben. Lesen kann Bilden. :)
Liebe Grüße,
Venushügel. :thumbup:

Mr.Fisch

Hausmeister

  • »Mr.Fisch« ist männlich
  • »Mr.Fisch« ist ein verifizierter Benutzer
  • »Mr.Fisch« ist der Autor dieses Themas

Beiträge: 1 112

Wohnort: Bad Fallingbostel

Beruf: Medizin-Informatiker

Pokerstars ID: Mr.Fisch09

  • Private Nachricht senden

43

Montag, 9. Mai 2011, 20:18


bekomme beim klick auf hall of fame und spielregeln die obige fehlermeldung hat jemand ne idee woan es liegen koennte
gruss house[/b]

Hi House,

wie Venus bereits geschrieben hat war für kurze Zeit ein Download (V1.3) im Umlauf wo Teile der Bibliothek fehlten. Im neuen Download (V1.3a) ist alles komplett. Für das Update reicht es alle Dateien über zu kopieren.
Hier die aktuelle Version: http://offlineweb.servebbs.com/wbb3/inde…nload&dataID=18

Ciao Mr.Fisch

44

Montag, 9. Mai 2011, 20:41

hall of fame geht aber bei spielinfo kommt
Warning: file_exists() [function.file-exists]:
open_basedir restriction in effect.
File(/tmp/%%8E^8EB^8EBF00C3%%info.tpl.php) is not within the allowed
path(s):
(/srv/www/httpd/phost/e/de/emderonline/web:/srv/www/httpd/phost/e/de/emderonline/tmp:/srv/www/httpd/phost/e/de/emderonline/ses)
in /srv/www/httpd/phost/e/de/emderonline/web/wbb/go/vcl/smarty/libs/Smarty.class.php on line 1379



Fatal error: Smarty error: the $compile_dir '/tmp' does not exist, or is not a directory. in /srv/www/httpd/phost/e/de/emderonline/web/wbb/go/vcl/smarty/libs/Smarty.class.php on line 1092
wo muss denn das tmp verzeichnis sein hab schon alles probiert aber geht nich


Mr.Fisch

Hausmeister

  • »Mr.Fisch« ist männlich
  • »Mr.Fisch« ist ein verifizierter Benutzer
  • »Mr.Fisch« ist der Autor dieses Themas

Beiträge: 1 112

Wohnort: Bad Fallingbostel

Beruf: Medizin-Informatiker

Pokerstars ID: Mr.Fisch09

  • Private Nachricht senden

45

Montag, 9. Mai 2011, 21:08

Mit meinen Windows-Systemen konnte ich das leider nur bedingt testen, aber Venus hatte eine Lösung gefunden....
Smarty will tmp im root nutzen, habe ich jedoch nicht im open_basedir mit angegeben, nun funzt es. Grad erst raus gefunden gehabt. :)

46

Dienstag, 10. Mai 2011, 15:08

komme aber nicht auf das root verzeichnis von meinem hoster weiss denn jemand in welcher config das steht dann koennte man es ja dort aendern

gruss house

47

Dienstag, 10. Mai 2011, 17:49

das tmp Verzeichnis muß in der php.ini bei open_basedir mit drinne stehen. Es gibt auch einen Befehl, sowas in eine php Datei zu schreiben, jedoch weiß ich nicht, wie die Zeile aussehen muß. :( Funktionieren tut sowas aber auch nicht immer.
Liebe Grüße,
Venushügel. :thumbup:

Mr.Fisch

Hausmeister

  • »Mr.Fisch« ist männlich
  • »Mr.Fisch« ist ein verifizierter Benutzer
  • »Mr.Fisch« ist der Autor dieses Themas

Beiträge: 1 112

Wohnort: Bad Fallingbostel

Beruf: Medizin-Informatiker

Pokerstars ID: Mr.Fisch09

  • Private Nachricht senden

48

Sonntag, 22. Januar 2012, 14:02

Es gibt ein Update auf Version 1.3b:
Ich habe meine Webseite mal komplett aktualisiert. Dabei sind mir Inkompatibilitäten zu PHP 5.3.x und MySQL 5.x bei der VCL4PHP Bibliothek aufgefallen.
In der V1.3b sind deshalb 3 Bibliothek-Dateien im go/vcl verzeichnis angepasst worden.

Ciao Mr.Fisch

49

Montag, 21. Januar 2013, 17:20

Ostfriesisches Deichwandern.

Hallo.

Leider habe auch ich Probleme mit dem Spiel und mir schon die Augen viereckig gelesen, aber finde leider die Lösung nicht.

Nach dem drücken auf den Button "Deich-Administration" bekomme ich folgende Fehlermeldung:

Application raised an exception class EDatabaseError with message 'Cannot connect to database server'



Callstack #0 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/deich_admin.php Line: 3
|_Callstack #1 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/dbmodule.php Line: 46
|_Callstack #2 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/classes.inc.php Line: 1925
|_Callstack #3 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/classes.inc.php Line: 2022
|_Callstack #4 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/classes.inc.php Line: 632
|_Callstack #5 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/classes.inc.php Line: 556
|_Callstack #6 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/dbmodule.php Line: 29
|_Callstack #7 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/system.inc.php Line: 330
|_Callstack #8 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/dbtables.inc.php Line: 155
|_Callstack #9 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/db.inc.php Line: 431
|_Callstack #10 File: /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/dbtables.inc.php Line: 287


Habe mir hier im Board das aktuellste Paket runtergeladen.

Ein paar Daten von meiner Umgebung:

PHP-Version: 5.2.17

SQL-Version: 5.0.96

Board-Version wbb2.3.6pl2

Link zum Board.


Das Spiel ist im Moment nicht verlinkt bzw. freigegeben, weil es ja nicht funtzt.



Was ist zu tun und in welcher Datei?



Könnt Ihr mir bitte helfen?



Vielen Dank.

MfG

ZeroG

Mr.Fisch

Hausmeister

  • »Mr.Fisch« ist männlich
  • »Mr.Fisch« ist ein verifizierter Benutzer
  • »Mr.Fisch« ist der Autor dieses Themas

Beiträge: 1 112

Wohnort: Bad Fallingbostel

Beruf: Medizin-Informatiker

Pokerstars ID: Mr.Fisch09

  • Private Nachricht senden

50

Montag, 21. Januar 2013, 21:26

Hallo ZeroG,

laut Fehlermeldung ist das Problem der Connect bei der Datenbank. Die Anmeldedaten werden in der "configure.php" gepflegt.

Grüße aus Hamburg
Marcel

51

Montag, 21. Januar 2013, 23:44

Hallo Mr. Fisch.



Ja das ist mir wohl bekannt. Die habe ich dort auch eingegeben und mit verschiedenen Sachen experemtiert (root, localhost), aber es kommt kein connect zustande.



MfG

ZeroG

52

Dienstag, 22. Januar 2013, 05:48

Moin moin.

So nun habe ich es rausgefunden, warum der Connect nicht zu stande kam, es lag am db-name. Evtl. mal genauer in der Anleitung darauf hinweisen.

Spiel konnte gestartet werden. Bei der HOF kamen Fehlermeldungen die ich mit Hilfe dieses Threads beseitigen konnte (Stichwort = Groß,- und Kleinschreibung). Aber bei den Spielregeln bekomme ich auch, wie einige vor mir die Fehlermeldung:

Warning: require_once(smarty/libs/smarty.class.php) [function.require-once]: failed to open stream: No such file or directory in /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/smartytemplate.inc.php on line 53

Fatal error: require_once() [function.require]: Failed opening required 'smarty/libs/smarty.class.php' (include_path='.:/usr/local/pd-admin2/php5/lib/php') in /home/s2verdbk/www.vertigo4way.de/wbb2/go/vcl/smartytemplate.inc.php on line 53




In der Datei go/vcl/smartytemplate.inc.php steht in Zeile #53:

require_once("smarty/libs/Smarty.class.php"); Also das S bei Smarty.class.php auch groß geschrieben, dieses habe ich geändert, aber ohne Erfolg.

Hier komme ich nicht weiter. Wo finde ich denn die "smarty/libs/smarty.class.php"? Was kann ich tun, wenn ich keinen Zugriff auf den Server bzw. die php.ini habe?

Leider habe ich auch in diesem Thread schon zu oft gelesen, dass etwas gefixt sein soll (Stichwort = Groß,- und Kleinschreibung), was denn aber doch nicht ist. Kein Hack bzw. Addon macht soviel Probleme wie dieses. Sorry soll kein meckern sein, nur nen Denkanstoß.

Ich hoffe dennoch auf Hilfe.

MfG

ZeroG

53

Mittwoch, 23. Januar 2013, 17:41

Moin moin.

Ich noch mal . Habe mir die ganze Sache, noch mal in Ruhe angeschaut und habe es mit Hilfe von diesem Thread nun hinbekommen.

Der Ordner smarty wurde aus irgendeinem Grund nicht mit kopiert. Als ich das nachgeholt habe, hatte es noch ne Fehlermeldung gegeben, weil ich in der Datei -go/vcl/smartytemplate.inc.php- die Zeile #53 geändert hatte. Ich hatte aus der Smarty.class.php "smarty.class.php" gemacht, also klein geschrieben. In dem Ordner go/vcl/smarty/libs wird diese Datei aber groß geschrieben (eigentlich ungewöhnlich), nachdem das wieder geändert war, funktiert jetzt auch der Button bzw. die Seite mit den Spielregeln.

Good Luck

Bis später

ZeroG

Mr.Fisch

Hausmeister

  • »Mr.Fisch« ist männlich
  • »Mr.Fisch« ist ein verifizierter Benutzer
  • »Mr.Fisch« ist der Autor dieses Themas

Beiträge: 1 112

Wohnort: Bad Fallingbostel

Beruf: Medizin-Informatiker

Pokerstars ID: Mr.Fisch09

  • Private Nachricht senden

54

Mittwoch, 23. Januar 2013, 19:05

@ZeroG:
Das freut mich erst einmal :)

Die Probleme mit der Bibliothek tun mir leid. Es ist der Versuch, Software sowohl für das WBB2, als auch für das WBB3 zur Verfügung zu stellen.

Ciao Marcel

55

Donnerstag, 24. Januar 2013, 13:18

Hallo.

Ein habe ich aber noch.

Im Firefox (v18.0.1) funktioniert ein Link nicht, und zwar, wenn ich im Deich-Admin-Bereich bin "zurück zum Deichwandern". Dort wird der Link wie folgt ausgelesen:
www.meine-url.de/wbb2/go/..\odw.phhp

Dadurch kommt es natürlich zur Fehlermeldung, dass er die Seite nicht finden kann:
The requested URL /wbb2/go/..\odw.php was not found on this server.

Im übrigen wird hier auch das Fenster von dem Bereich, "Deich-Admin" und "Spielgregeln", in der Tabellenhintergrundfarbe dargestellt, bei mir rot.

Im IE #8 wird er richtig ausgelesen, dort wie folgt:
www.meine-url.de/wbb2/odw.phhp

In diesem Browser werden die fenster in weiß dargestellt, was ich persönlich besser finde.



Wie kann ich das beheben, in welcher Datei muss ich was ändern?
Wenn sich auch nicht die Farben ändern lassen, weil ja bekanntlich jeder Browser alles anders interpretiert, so muss es aber ne Lösung für den Link geben.

MfG
ZeroG

Mr.Fisch

Hausmeister

  • »Mr.Fisch« ist männlich
  • »Mr.Fisch« ist ein verifizierter Benutzer
  • »Mr.Fisch« ist der Autor dieses Themas

Beiträge: 1 112

Wohnort: Bad Fallingbostel

Beruf: Medizin-Informatiker

Pokerstars ID: Mr.Fisch09

  • Private Nachricht senden

56

Donnerstag, 24. Januar 2013, 17:02

Danke für den Hinweis. Ich werde das testen. Die Programmierung liegt leider schon etwas zurück, deshalb brauche ich eine Weile um mich wieder rein zu arbeiten. Es wird wohl mal wieder Zeit für ein Update :)

Alle paar Monate mache ich ja in meinem cBall-Forum eine Deichwanderung (http://cball.dyndns.org/wbb2/odw.php). Dort wurden mir zumindest von Mitspielerseite keine Probleme mit unterschiedlichen Browsern gemeldet.

Ciao Marcel (alias Mr.Fisch)

57

Donnerstag, 24. Januar 2013, 20:16

Hi.

Wie gesagt, es taucht nur bei der Deich-Admin-Seite auf. Also wenn nur Du der Deichadmin bist, musst Du es mal mit nem anderen Browser versuchen, wenn ein anderer User der Deichadmin ist sollte der es mal versuchen.

Bei Spielregeln und hof funktioniert der Link "zurück zur Deichwanderung" ja.

In der Datei "go/deich_info.xml.php" verweist Du ja mit der Codezeile:

<property name="TemplateFilename">templates/info.tpl</property>

in das Template "info.tpl" wo der Link halt so: "<p align="center"><strong><a href="../odw.php" target="_top">[ zur&uuml;ck zur Deichwanderung ]</a></strong></p>" drinsteht.

In dem Template "hof.tpl" steht der Link zwar auch so: "<a href="../odw.php" target="_top">[ zur&uuml;ck zum Deichwandern ]</a></div>" drin, aber in der Datei "go/deich_hof.xml.php" wird nicht auf das Template verwiesen.

In der Datei "go/deich_admin.xml.php" und in der "go/deich_hof.xml.php" steht der Link so drin:

<property name="Link">..\odw.php</property>

Würde mich über eine Lösung freuen.

Zur Not trenne es halt für das wbb2.3.x und dann noch mal für das wbb3.x.x, wenn es so nicht kompatibel ist.

Vielen Dank.

MfG

ZeroG

58

Sonntag, 27. Januar 2013, 13:53

Hi Mr. Fisch.

Und schon eine Lösung gefunden?
Gibt es schon einen Workaround?

MfG
ZeroG

Mr.Fisch

Hausmeister

  • »Mr.Fisch« ist männlich
  • »Mr.Fisch« ist ein verifizierter Benutzer
  • »Mr.Fisch« ist der Autor dieses Themas

Beiträge: 1 112

Wohnort: Bad Fallingbostel

Beruf: Medizin-Informatiker

Pokerstars ID: Mr.Fisch09

  • Private Nachricht senden

59

Sonntag, 27. Januar 2013, 15:51

Sorry, ich kann mich frühestens nächste Woche darum kümmern. Bin diese WE total busy.

Mr.Fisch

60

Samstag, 2. März 2013, 12:54

Moin Mr. Fisch.

Wollte mal nachfragen, ob es schon was neues, bzw. eine Lösung gibt.

MfG
ZeroG

Zurzeit sind neben dir 2 Benutzer in diesem Thema unterwegs:

2 Besucher

Social Bookmarks

Counter:

Gezählt seit: 8. Februar 2011, 12:24 | Hits heute: 4 080 | Hits gestern: 4 036 | Klicks heute: 4 230 | Hits gesamt: 2 234 524 | Klicks gesamt: 2 578 491